WordPress plugin intelligence profile

Apocalypse Meow

A simple, light-weight collection of tools to harden WordPress security and help mitigate common types of attacks.

WP PlugIndex snapshot

Current directory snapshot

Tested up to WordPress 7.1
Current version23.2.0
WordPress coverageTested up to WordPress 7.1
Minimum stackWP 4.4 · PHP 7.4
Directory statusactive
Last directory update14 Oct 202618d ago
Active installations300Adoption metric — not a quality score
WordPress.org rating5.0 / 5 from 23 ratings
Official packageDirect from WordPress.org

Repository metrics are context, not quality scores. Active installations measure adoption and can strongly reflect a plugin’s age and historical popularity. Ratings, recent updates and “Tested up to” metadata also do not guarantee modern code, error-free operation, security, feature completeness or suitability for a particular site. Why active installs don’t tell the whole story →

WP PlugIndex currently records Apocalypse Meow version 23.2.0 as active, updated 18d ago and tested up to WordPress 7.1.

Overview

About this plugin

Apocalypse Meow’s main focus is addressing WordPress security issues related to user accounts and logins. This includes things like:

  • Brute-force login-in protection;
  • Customizable password strength requirements;
  • XML-RPC access controls;
  • Account access alerts;
  • Searchable access logs (including failed login attempts and temporary bans);
  • User enumeration prevention;
  • Registration SPAM protection;
  • Miscellaneous Core and template options to make targeted hacks more difficult;
  • Anonymize/scrub leaky remote request headers;

Security is an admittedly technical subject, but Apocalypse Meow strives to help educate “normal” users about the nature of common web attacks, mitigation techniques, etc. Every option contains detailed explanations and links to external resources with additional information.

Knowledge is power!

Requirements

Due to the advanced nature of some of the plugin features, there are a few additional server requirements beyond what WordPress itself requires:

  • WordPress 4.4+.
  • PHP 7.4 or later.
  • PHP extensions: (bcmath or gmp), date, filter, pcre.
  • CREATE and DROP MySQL grants.
  • Single-site Installs (i.e. Multi-Site is not supported).

Please note: it is not safe to run WordPress atop a version of PHP that has reached its End of Life. Future releases of this plugin might, out of necessity, drop support for old, unmaintained versions of PHP. To ensure you continue to receive plugin updates, bug fixes, and new features, just make sure PHP is kept up-to-date.

🙂

Log Monitoring

Some robots are so dumb they’ll continue trying to submit credentials even after the login form is replaced, wasting system resources and clogging up the log-in history table. One way to mitigate this is to use a server-side log-monitoring program like Fail2Ban or OSSEC to ban users via the firewall.

Apocalypse Meow produces a 403 error when a banned user requests the login form. php. Additionally, some robots are unable to follow redirects; if your login form requires SSL, you should also ban repeated 301/302 responses to catch those fools.

author=X will produce a 400 response code which can be similarly tracked.

Privacy Policy

When active, this plugin retains security logs of every sign-in attempt made to the CMS backend. This information — including the end user’s public IP address, username, and the status of his or her attempt — is used to help prevent unauthorized system access and maintain Quality of Service for all site visitors.

This information resides fully on the hosting web site and is not shared with any third parties.

Data retention is entirely up to the site operator, but by default old records are automatically removed after 90 days.

Please note: Apocalypse Meow DOES NOT integrate with any WordPress GDPR “Personal Data” features. (Selective erasure of audit logs would undermine the security mechanisms provided by this plugin. )

WordPress.org metadata

Plugin tags

Topics listed for this plugin in the WordPress.org directory.

  • brute force
  • login
  • security
Compatibility & maintenance

Compatibility & maintenance

Tested with WP 7.1

Marked as tested with the current WordPress 7.1 release.

Current WordPress releaseWordPress 7.1
WordPress.org Tested up to7.1
Minimum requirementsWordPress 4.4 · PHP 7.4
Update activity14 Oct 202618d ago

“Tested up to” is directory metadata supplied by the plugin author. WP PlugIndex does not turn an older declaration into a claim that the plugin is incompatible.

Changes recorded by WP PlugIndex

Recent tracked changes

Version23.1.123.2.0
WordPress compatibility7.27.1.3
WordPress compatibility7.17.2
Tracking & source

WP PlugIndex tracks public WordPress.org directory metadata and records selected version, compatibility and availability changes as they are detected.

Plugin watchlist

Watch this plugin

Sign in to your WP PlugIndex account or create a free account. Free accounts can watch up to 5 plugins and see what changed.

Watch limit

Watchlist limit reached

You have reached your current active watch limit.